Languages

Export excel to CSV with UTF-8 encoding - problem

1 points
Asked by:
AnnLen
1858

How can I export excel to CSV file with UTF-8 encoding?

If I export with default excel encoding I get some artifacts like wrong letters - eg I have some Polish characters like: ó, ź, ą, ę, ł etc.

When I export to csv all those characters get wrong encoding. 

Example:

3,Pozna?
4,Warszawa
5,Kraków
7,Rzeszów
8,Wroc?aw

First row should be: 3, Poznań

But instead I get: 3,Pozna?

How to solve this problem?

Entire data after export should looks like this:

3,Poznań
4,Warszawa
5,Kraków
7,Rzeszów
8,Wrocław

I use Microsoft Office Excel 2013

2 answers
3 points
Answered by:
AnnLen
1858

Easiest way to solve this problem is to copy from excel to google docs excel and export data from there.

In google docs excel go to:

File -> Download -> Comma-separated values (.csv, current sheet)

Screenshot:

 

Your data in google docs excel:

Your data after export from google docs excel:

 

0 comments Add comment
2 points
Answered by:
AnnLen
1858

Coppied from following wiki article: https://dirask.com/posts/p59o0p

Do followin steps:

  1. go to: File -> Export -> Change File Type -> Save as Another File Type -> Save As,
  2. set Save as type to CSV UTF-8 (Comma dellimited) (*.csv)

Export -> Save As option screenshot: 

Export excel data to UTF-8 csv file.
Export excel data to UTF-8 csv file.

File preview with Notepad++:

Exported excel data to UTF-8 csv file.
Exported excel data to UTF-8 csv file.
1 comments
AnnLen
I don't have such option, I use excel 2013.
Add comment
Hey 👋
Would you like to know what we do?
  • Dirask is online IT community for professionals and hobbyist to share their knowledge and help each other in extraordinary easy way.
  • We welcome everyone
    no matter what the experience,
    no matter how basic the question is,
    this community will help you.