During instalation Redmine 3.4.11 on my Debian 9 (Stretch), I got following error:
Gem::InstallError: sprockets requires Ruby version >= 2.5.0. An error occurred while installing sprockets (4.0.2), and Bundler cannot continue. Make sure that `gem install sprockets -v '4.0.2'` succeeds before bundling.
I was doing everything acccording to official instrucction:
In Debian 9 repositories I dont have indicated version.
Should I install newest Ruby manually?
Somewhere in the internet I have found that It should be working by default.
Do following steps to solve the problem:
- open Gemfile file:
- add line:
gem "sprockets", "~> 3.7.2"
- run installation again.