Redmine - sprockets requires Ruby version >= 2.5.0

4 points
Asked by:

During instalation Redmine 3.4.11 on my Debian 9 (Stretch), I got following error:

Gem::InstallError: sprockets requires Ruby version >= 2.5.0.
An error occurred while installing sprockets (4.0.2), and Bundler cannot continue.
Make sure that `gem install sprockets -v '4.0.2'` succeeds before bundling.

I was doing everything acccording to official instrucction:

In Debian 9 repositories I dont have indicated version.

Should I install newest Ruby manually?

Somewhere in the internet I have found that It should be working by default.

1 answer
1 points
Answered by:

Do following steps to solve the problem:

  1. open Gemfile file:
  2. add line:
    gem "sprockets", "~> 3.7.2"
  3. run installation again.


Redmine installation error solution - sprockets requires Ruby version >= 2.5.0

0 comments Add comment
Native Advertising
Get your tech brand or product in front of software developers.
For more information Contact us
Dirask - we help you to
solve coding problems.
Ask question.

❤️💻 🙂