Languages

Redmine - sprockets requires Ruby version >= 2.5.0

4 points
Asked by:
JustMike
3533

During instalation Redmine 3.4.11 on my Debian 9 (Stretch), I got following error:

Gem::InstallError: sprockets requires Ruby version >= 2.5.0.
An error occurred while installing sprockets (4.0.2), and Bundler cannot continue.
Make sure that `gem install sprockets -v '4.0.2'` succeeds before bundling.

I was doing everything acccording to official instrucction:
https://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_on_Debian_9

In Debian 9 repositories I dont have indicated version.

Should I install newest Ruby manually?

Somewhere in the internet I have found that It should be working by default.

1 answers
1 points
Answered by:
JustMike
3533

Do following steps to solve the problem:

  1. open Gemfile file:
    /opt/redmine/redmine-3.4.11/Gemfile
  2. add line:
    gem "sprockets", "~> 3.7.2"
  3. run installation again.

Screenshot:

Redmine installation error solution - sprockets requires Ruby version >= 2.5.0

0 comments Add comment
Hey 👋
Would you like to know what we do?
  • Dirask is a friendly IT community for learners, professionals and hobbyists to share their knowledge and help each other in extraordinary easy way.
  • We welcome everyone,
    no matter what the experience,
    no matter how basic the question is,
    this community will help you.