Languages

How to fix git problem - error: unable to start editor 'emacs'?

2 points
Asked by:
Marcin
16180

My problem description:

When I make git pull I have an error:

error: unable to start editor 'emacs'

How can I fix it?

1 answer
7 points
Answered by:
Marcin
16180

FIX:

You can fix this problem by setting vim editor as your default git editor. Most linux distro will have vim by default:

To set git editor to vim, we need to execute below command:

git config --global core.editor vim

You could also install emacs editor, but most prople prefered vim over vi and emacs.

0 comments Add comment
Native Advertising
­čÜÇ
Get your tech brand or product in front of software developers.
For more information Contact us
Dirask - friendly IT community for everyone.

ÔŁĄ´ŞĆ­čĺ╗ ­čÖé

Join