Languages

CentOS 7 problem with python - Error: Package: python-paramiko-2.1.1-9.el7.noarch (/python-paramiko-2.1.1-9.el7.noarch) Requires: python-cryptography

7 points
Asked by:
JustMike
26150

I have a problem.

During automated instalation I encountered below problem:

Error: Package: python-paramiko-2.1.1-9.el7.noarch (/python-paramiko-2.1.1-9.el7.noarch)
           Requires: python-cryptography
Error: Package: python-paramiko-2.1.1-9.el7.noarch (/python-paramiko-2.1.1-9.el7.noarch)
           Requires: python2-pyasn1
Error: Package: ansible-2.8.5-1.el7.noarch (/ansible-2.8.5-1.el7.noarch)
           Requires: python2-cryptography

Automation is made with ansible.

Anyone have an idea how to solve it?

1 answer
4 points
Answered by:
JustMike
26150

To solve this problem we need to install python-paramiko. It will fix the problem.

Steps:

1. Install wget (if we don't have it, already)

sudo yum install wget -y

2. Download python-paramiko with below command:

wget http://mirror.centos.org/centos/7/os/x86_64/Packages/python-paramiko-2.1.1-9.el7.noarch.rpm

3. Install python-paramiko with yum:

yum install python-paramiko-2.1.1-9.el7.noarch.rpm -y

 

0 comments Add comment
Native Advertising
50 000 ad impressions - 449$
🚀
Get your tech brand or product in front of software developers.
For more information contact us:
Red dot
Dirask - friendly IT community for everyone.

❤️💻 🙂

Join